Avid S3L and 3rd-party AVB Devices

This article describes how to connect and use MOTU AVB audio interfaces with the Avid S3L-X console.

For years, I have wanted to connect my MOTU AVB audio interfaces to my Avid S3L console, but have had no luck. After recently finding some information on the internets, I’ve found a way to reconfigure the S3L to talk using 8-channel AVB streams, which my MOTU devices require, and with some effort I now have bi-directional audio working!!

I’ve written up a document, and shared it as a public Google doc. I’ll eventually write it up here, but don’t feel like messing with WordPress right now.

Avid S3L-X and 3rd Party AVB (a Google Doc)

I look forward to any feedback!!

Avid S3L-X, AVB, and the Netgear GS724Tv4 network switch

I’m part of the audio team at ICF, and learned that we had an unused Netgear GS724Tv4  network switch lying around. The switch was originally purchased to connect multiple AVB devices together, similar to the MOTU AVB Switch, but with more ports, and because the MOTU doesn’t work with the Avid S3L. Unfortunately, nobody had ever gotten it to work with AVB, so I took a stab and wrote up the instructions below.

Using a Netgear GS724Tv4 network switch to pass AVB between a Mac Pro and the Avid S3L-X

I can confirm that the switch works (firmware version 6.3.1.19 tested).

Starting with factory default settings, here are the step-by-step instructions. These instructions came from Updating Netgear GS724Tv4 config for Tesira AVnu certification with one small modification.

  1. Click on the Switching tab, then click on the Auto-VoIP sub-page. In the “Protocol Based Port Settings” table, click the checkbox in the top-left corner to select all ports and enable Auto VoIP Mode for all ports. Then, click Apply in the bottom-right corner.
  2. Click on the 802.1AS sub-page. Set the 802.1AS Status to Enable. Then, click Apply in the bottom-right corner. There will be an EAV advisory note which pops up after you hit Apply, which you can ignore.
  3. While still on the 802.1AS sub-page click on the Advanced > 802.1AS Port Settings. In the purple header row at the top of the list select the check box to select all ports. (Consider to uncheck ports g25 and g26 to prevent AVB traffic flowing into the backbone network.) Enter a value of 5000 for the Pdelay Threshold. Then, click Apply in the bottom-right corner.
  4. Click on the MRP sub-page. Set the MSRP Mode to Enable. Ensure that all other options are disabled. Also, set MSRP Max Fan In Ports to 26. Then, click Apply in the bottom-right corner. There will be an EAV advisory note which pops up after you hit Apply, which you can ignore.
  5. While still on the MRP sub-page click on the Advanced > MRP Port Settings. In the purple header row at the top of the list click the checkbox to select all ports and then select Enable for MVRP Mode and MSRP Mode and enter values of 20 for the Join Time, 120 for the Leave Timer, and 2500 for the Leave All Timer. Then, click Apply in the bottom-right corner.
  6. Click on the VLAN sub-page. Under the Advanced settings choose Voice VLAN Configuration. Enable the Voice VLAN Global Admin Mode at the top of the page. Then, click Apply in the bottom-right corner.
  7. While still on the VLAN sub-page, under the Advanced settings choose VLAN Membership. In the  VLAN ID dropdown choose VLAN ID 2, in the Group Operation dropdown choose Tag All. Then, click Apply in the bottom-right corner.
  8. Click on the LAG sub-page. In the purple header row at the top of the LAG Configuration list select the check box to select all ports and select Disable for Admin Mode, STP Mode, and Link Trap.  Then, click Apply in the bottom-right corner.
  9. Power cycle the switch.

The one small modification to the instructions was in step 4, where I removed references to MVRP. In my experience, enabling MVRP will cause the E3 to lose connection to its internal network switch, and the only way to fix this is to cleanly shutdown the E3, then remove the power plug and wait for the green power light to go out. I did not test enabling it for everything except the E3. (Apparently this is a known issue — search for VSW-10570 in the “What’s New in VENUE 4.6.1” document that comes with the VENUE 4.6.1 release.)

If you want to use Dante and AVB together, I suggest reading the Using Dante and AVB protocols together on the Netgear GS724Tv4 switch document. As of 2018-01-22 I haven’t tested those instructions.

Avid VENUE S3L-X, AVB, and macOS High Sierra

Long story short, if you need use an Avid S3L-X with macOS and playback via AVB, do not install macOS High Sierra. macOS Mojave works fine, as does the older macOS Sierra, but High Sierra has clocking issues that manifest as constant clicking during playback, rendering the audio unusable.

If all you need to do is record via AVB, macOS High Sierra works without issue.

References

Note, all versions of macOS High Sierra through 10.13.6 are affected.

[Update 2019-03-03] I continue to have no problems with macOS Mojave (currently 10.14.3).
[Update 2018-09-29] Preliminary testing with macOS Mojave (10.14.0) and 64-channel recording and playback indicates that the AVB problems have been fixed.
[Update 2018-07-28]
Increased affected versions to 10.13.6.
[Update 2018-06-05]
Increased affected versions to 10.13.5.
[Update 2018-03-31]
Increased affected versions to 10.13.4.