Categories
Solution

Stop Avid Link from starting at boot

TL;DR Avid Link starts at boot, and there is no setting in the app to prevent launching at boot. I hate software that doesn’t allow me to control whether it starts automatically!

To stop Avid Link from launching on macOS at boot, run the following command from a Terminal. It is a long line, so make sure to copy the whole thing. You will be asked for your password.

sudo defaults write /Library/LaunchAgents/com.avid.avidlink.plist RunAtLoad -boolean false

To again allow Avid Link to start at boot, run the same command again, changing the “false” to “true”.

Background

I’m not a fan of software makers taking action on my computers without my awareness. One of the most annoying things companies do is that they install something that starts at every boot – without asking – because they mistakenly believe that their software always needs to be running, and that I as a user am not smart enough to make that decision on my own. Even worse than not asking is not even giving the permission to stop the software from starting at boot.

As you can see, Avid Link gives me no option to disable the launch at boot, only that it is hidden after launch.

Looking in the standard location for controlling such things (System Preferences > Users & Groups > Login Items), Avid Link isn’t listed.

As you can see, I’m not against things starting at boot, only things that I cannot control!

2 replies on “Stop Avid Link from starting at boot”

Leave a Reply

Your email address will not be published. Required fields are marked *